bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21028: Performance regression in revision af1a69f4d17a482c359d98c00e


From: Eli Zaretskii
Subject: bug#21028: Performance regression in revision af1a69f4d17a482c359d98c00ef86fac835b5fac (Apr 2014).
Date: Mon, 19 Dec 2016 17:50:31 +0200

> Cc: address@hidden
> From: Clément Pit--Claudel <address@hidden>
> Date: Sun, 18 Dec 2016 15:44:20 -0500
> 
> >> It works!  But only for the original example (with Arial), AFAICT.  Do you 
> >> know what the equivalent fix would be for the recipe given in 
> >> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=21028#62 ?
> > 
> > The same: use :family and :registry instead of :name.  What did you
> > try?
> 
> I tried this, but it was didn't seem to make a difference:
> 
> (dolist (frame (frame-list))
>   (dolist (fontset (fontset-list))
>     (set-fontset-font fontset 'unicode (font-spec :family "Segoe UI Emoji" 
> :registry "iso10646-1") frame 'append)
>     (set-fontset-font fontset 'unicode (font-spec :family "XITS 
> Math":registry "iso10646-1") frame 'append)))
                     ^^^^^^^
You want 'prepend, not 'append, I think.

But if using 'prepend' doesn't work, please explain what "didn't seem
to make a difference" means.  I tried the above with 'prepend', and
the Emoji characters are displayed using the Segoe font.

Also, using 'unicode' is gross, IMO; it's better to specify specific
ranges of characters you want to be displayed using the font family.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]