bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25061: consider adding %COMPAT to default gnutls priority string


From: Ted Zlatanov
Subject: bug#25061: consider adding %COMPAT to default gnutls priority string
Date: Thu, 01 Dec 2016 13:32:43 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

On Tue, 29 Nov 2016 11:24:53 +0100 Andy Wingo <address@hidden> wrote: 

AW> There have been reports of errors from people using melpa and so on
AW> which manifest themselves as:

AW>     gnutls.c: [0] (Emacs) fatal error: The TLS connection was non-properly 
terminated.
...
AW> So, as Ludovic suggests in his message, a workaround might be:

AW>     (setq gnutls-algorithm-priority "NORMAL:%COMPAT")

AW> See Ludovic's message for some justification.  Just an idea.  I have
AW> been trying to reproduce the problem that people report locally as some
AW> TLS errors but I have not been able to.

We could break down %COMPAT to all its components and find which ones
are causing the issue.

I wouldn't make %COMPAT part of the default. For the sake of accessing
some sites, we'd make all our users less secure. But if the connection
fails, maybe we can suggest setting it for just that site. That's not
trivial right now but I plan to add that capability.

Ted





reply via email to

[Prev in Thread] Current Thread [Next in Thread]