bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23561: epg tests are (almost) always skipped


From: Daiki Ueno
Subject: bug#23561: epg tests are (almost) always skipped
Date: Thu, 19 May 2016 10:40:49 +0900
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Glenn Morris <address@hidden> writes:

>> as long as "gpg2" is GnuPG 2.0
>
> epg-config--program-alist requires gpg2 to be in the 2.1 series, so that
> seems a bit contradictory?
>
> If these are tests for gpg v1, could you not bind epg-gpg-program to
> "gpg" in epg-tests-gpg-usable and with-epg-tests (when
> require-passphrase is set)?

The problem is that some distributions rename "gpg2" to "gpg" and it's
not that simple to detect it's v1.  Maybe a better solution would be to
define `epg-config--program-alist' as a normal defvar rather than
defconst, bind it in `with-epg-tests', and find the correct gpg v1
executable.  I'll try to write a patch later today.

Regards,
-- 
Daiki Ueno





reply via email to

[Prev in Thread] Current Thread [Next in Thread]