bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#18829: 25.0.50; (emacs) manual: relation between `package-initialize


From: Lars Ingebrigtsen
Subject: bug#18829: 25.0.50; (emacs) manual: relation between `package-initialize' and `require' & `load-path'
Date: Sat, 30 Apr 2016 16:49:02 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Drew Adams <address@hidden> writes:

> There is apparently a fair amount of confusion, especially by new users, 
> about the relation between `require' and `load-path', on
> the one hand, and `package-initialize', on the other.  
>
> The doc for these is not together (which is normal), and it might help
> to (a) provide cross references and (b)

I've now done this...

> explicitly say that if you use `package-initialize' then you do
> (should) not need to explicitly adjust `load-path' and `require' the
> relevant code.

And this.

-- 
(domestic pets only, the antidote for overdose, milk.)
   bloggy blog: http://lars.ingebrigtsen.no





reply via email to

[Prev in Thread] Current Thread [Next in Thread]