bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23362: 25.0.93; Unicode chars (such as 0x1F600) are not rendered cor


From: Peter Wang
Subject: bug#23362: 25.0.93; Unicode chars (such as 0x1F600) are not rendered correctly
Date: Mon, 25 Apr 2016 04:59:17 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.92 (darwin)

Eli Zaretskii <address@hidden> writes:

>> From: Peter Wang <address@hidden>
>> Date: Mon, 25 Apr 2016 01:40:59 +0800
>> 
>> On OSX, this pretest release breaks render of some unicode chars.
>> 
>> ;;; 😀😂
>> (set-frame-font "Monaco:pixelsize=16")
>> (set-fontset-font
>> (frame-parameter nil 'font)
>> 'symbol (font-spec :family "Apple Color Emoji") nil 'prepend)
>> 
>> there should be two symbols in the first line of above snippets if
>> rendered correctly.
>> 
>> BTW, the last pretest does not have such issue. the version of last
>> pretest is:
>> 
>> GNU Emacs 25.0.92.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 
>> 10.9.5 (Build 13F1603)) of
>> 2016-03-03
>
> Isn't this a consequence of this commit:
>
>   commit 9344612d3cd164317170b6189ec43175757e4231
>   Author: YAMAMOTO Mitsuharu <address@hidden>
>   Date:   Tue Apr 12 08:26:51 2016 +0900
>
>       Disable multicolor fonts on OS X since they are not supported on free 
> system
>
>       * src/macfont.m (macfont_list): Don't use color bitmap fonts.
>
> If you revert it, does the problem go away?  If not, can you please
> bisect the emacs-25 branch between 25.0.92 and now, and see which
> commit caused this?
>
> Thanks.

I tried to revert this commit (one line of code) on head
(e6d6a99455183bca5074b7601ad11d424da6442e) and rebuild it. Now the issue
goes away.

If I understand correctly, this part of code is OSX specific, how is it
related to other free system? Could you elaborate more on it, Thanks!






reply via email to

[Prev in Thread] Current Thread [Next in Thread]