bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23292: 24.5; Combining characters do not reliably combine


From: Eli Zaretskii
Subject: bug#23292: 24.5; Combining characters do not reliably combine
Date: Fri, 15 Apr 2016 11:32:29 +0300

> From: Alexis <address@hidden>
> Cc: address@hidden, address@hidden
> Date: Fri, 15 Apr 2016 18:17:48 +1000
> 
> 
> Eli Zaretskii <address@hidden> writes:
> 
> > No.  Type 'o', then "C-x 8 RET 337".
> 
> Done. i get the same result as the OP - i.e. the 'o' and the '/' 
> are visually separated - using both DejaVu Sans Mono (Book) and 
> Inconsolata-G (my default font).

Thanks.

This is strange.  I'm CC'ing Handa-san, perhaps there's some issue in
libm17n-flt or its database for this case.

For the record, the composition works for me on MS-Windows using the
Arial Unicode MS font, and the composition data looks quite different
(and makes much more sense to me) than what the OP shows:

  Composed with the following character(s) "̷" using this font:
    uniscribe:-outline-Arial Unicode 
MS-normal-normal-normal-sans-13-*-*-*-p-*-iso8859-1
  by these glyphs:
    [0 1 111 82 7 1 6 14 4 nil]
    [0 1 823 671 0 -5 -2 14 4 nil]

The OP said the composition data he gets is this:

  Composed with the following character(s) "̷" using this font:
    xft:-PfEd-DejaVu Sans Mono-normal-normal-normal-*-13-*-*-*-m-0-iso10646-1
  by these glyphs:
    [0 1 111 82 8 1 7 7 0 nil]
    [0 1 823 703 8 0 8 8 1 nil]

and the offsets in the second vector look wrong to me, FWIW.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]