bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22795: 25.0.91; Can't write read only file on w32


From: Eli Zaretskii
Subject: bug#22795: 25.0.91; Can't write read only file on w32
Date: Thu, 25 Feb 2016 20:09:34 +0200

> Date: Thu, 25 Feb 2016 09:08:38 -0800
> CC: <address@hidden>
> From: "Ota, Takaaki" <address@hidden>
> 
> Yes, I own and have full permission of the directory.  I noticed one
> thing when I tried other than C: drive.  An external USB drive with
> NTFS file system exhibits the same problem as C: drive.  A flash drive
> with FAT32 doesn't show the same problem.  Have you tried with NTFS?

I tried only with NTFS.

> I tried "emacs -Q" (actually "./runemacs -Q") and the result is the
> same.  On FAT32 the writing succeeds.  On NTFS the writing fails by
> Permission denied error.

Very strange.  I guess the only way forward is for you to step with
Edebug through save-buffer and its subroutines in files.el, and tell
what fails there and why.  Can you do that?  (Since this works on
FAT32, I suspect some issue with NT security, although 24.5 also used
ACLs...)

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]