[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9300: 24.0.50; `bounds-of-thing-at-point' does not return nil when j

From: Dmitry Gutov
Subject: bug#9300: 24.0.50; `bounds-of-thing-at-point' does not return nil when just after THING
Date: Tue, 23 Feb 2016 12:22:05 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Thunderbird/44.0

On 02/23/2016 08:37 AM, Drew Adams wrote:

This would be a breaking change. For instance, it will make
(bounds-of-thing-at-point 'symbol) unsuitable for use in a
completion-at-point-functions element,

Why do you think so?  Have you tried it?  It does not affect
the behavior for THING = `symbol' at all.

Tried it, and yes it does. Otherwise, I wouldn't understand what this bug is about.

to compute the first two values of the returned list, because
during completion you're most often "after" the symbol.

So?  Not a problem.  Put point after a symbol - you get the
same answer as now.

You're contradicting the very title of this bug report.

This is the design of the thingatpt code, and the reason why
`<=' instead of `<' is a bug:

   the function that is (get THING 'end-op) moves PAST the THING,
   so that point is not on the THING.  This is true generally, no
   matter the type of THING.

That's not a quote from thingatpt.el.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]