bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22613: 25.1.50; dired-aux missing require 'cl-lib


From: Eli Zaretskii
Subject: bug#22613: 25.1.50; dired-aux missing require 'cl-lib
Date: Sat, 13 Feb 2016 20:00:58 +0200

> From: Michael Heerdegen <address@hidden>
> Cc: address@hidden,  address@hidden
> Date: Sat, 13 Feb 2016 18:43:39 +0100
> 
> Eli Zaretskii <address@hidden> writes:
> 
> > Sorry, I'm confused: what does package.el have to do with this issue,
> > and what do you mean by "a built-in package" in this context?
> 
> I mean: in the package manager, cl-lib is listed as "built-in" package.
> And packages also have autoloads.  So maybe the autoload definition for
> cl-mapcan we didn't understand why it is dloaded at all comes from the
> package mechanism.  Just speculating.

Could be.  But what bothers me is that Emacs _knows_ it's autoloaded,
and from which file, but it cannot autoload it.  That shouldn't
happen, no matter where did the knowledge come from.  Right?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]