bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22582: 25.0.90; package-test fail on w64


From: Fabrice Popineau
Subject: bug#22582: 25.0.90; package-test fail on w64
Date: Mon, 8 Feb 2016 11:04:49 +0100


If I run the package-test-server.py and I try to connect from a browser with
http://0.0.0.0:8000/archive-contents, I get ERR_ADDRESS_INVALID.

But that I have the same error if I try to open:
http://xx.xx.xx.xx:8000/archive-contents with xx.xx.xx.xx being my current IP address.

I get the file only if I connect to http://127.0.0.1:8000/archive-contents.

So I suspect that it is a default setting of the firewall in Windows 10.

The python server script 
test/automated/data/package/package-test-server.py
runs explicitly on 127.0.0.1, so why not using this address in the test?
What does using 0.0.0.0 brings here in the package-test-update-archives-async test?


Fabrice


2016-02-07 21:50 GMT+01:00 Eli Zaretskii <address@hidden>:
> From: Fabrice Popineau <address@hidden>
> Date: Sun, 7 Feb 2016 20:17:59 +0100
> Cc: address@hidden
>
> The second problem is still there. Under Windows 10 and my setup, a 10049 error is reported
> when trying to connect to http://0.0.0.0:8000/

Thanks.  I guess it's something new with Windows 10, then.  (Error
10049 means "The requested address is not valid in its context.")



reply via email to

[Prev in Thread] Current Thread [Next in Thread]