bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22552: 25.1; 25.0.90 build fails on Mac OS X 10.11


From: YAMAMOTO Mitsuharu
Subject: bug#22552: 25.1; 25.0.90 build fails on Mac OS X 10.11
Date: Fri, 05 Feb 2016 18:15:57 +0900
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 Emacs/22.3 (sparc-sun-solaris2.8) MULE/5.0 (SAKAKI)

>>>>> On Thu, 4 Feb 2016 22:49:32 -0800, Henry Unger <address@hidden> said:

>> > $ pkg-config --cflags 'libxml-2.0 > 2.6.17'
>> > -I/usr/include/libxml2
>> 
>> > /usr/include does not exist per se.
>> 
>> This means libxml-2.0.pc in your installation of libxml2 is bogus.
>> IIUC, Apple does not provide us with libxml-2.0.pc in their SDK, so probably
>> you should have installed libxml2 on your own.
>> 
>> YAMAMOTO Mitsuharu
>> address@hidden

> It appears that the libxml-2.0.pc file was installed when I used brew to 
> install some package a few weeks ago. I renamed libxml-2.0.pc to something 
> else and re-ran the configure and make and it built without error. I'm sorry 
> for the false alarm and thanks for your assistance

Homebrew seems to require the installation of Command Line Tools for
Xcode.

  
https://github.com/Homebrew/homebrew/blob/master/share/doc/homebrew/Installation.md

If you follow the above instructions, then /usr/include will be
created and the build of Emacs will succeed.

                                     YAMAMOTO Mitsuharu
                                address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]