bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#19368: 25.0.50; NSM prompt is not self-explanatory enough


From: Eli Zaretskii
Subject: bug#19368: 25.0.50; NSM prompt is not self-explanatory enough
Date: Fri, 05 Feb 2016 09:42:27 +0200

> From: Lars Ingebrigtsen <address@hidden>
> Cc: address@hidden
> Date: Fri, 05 Feb 2016 14:35:13 +1100
> 
> > I suggest to change the prompt to something like this:
> >
> >   Continue connecting? ([N]o, [S]ession only, [A]lways)
> >
> > Alternatively, the first letter could be underlined (assuming we can
> > rely on every supported terminal to be able to display underlined
> > characters).
> 
> This has now been fixed, and it's using read-multiple-choice, which
> makes the character choices underline and bold on graphical systems, and
> "[l]ike this" on non-graphical ones.

Thanks.

> Some terminals do have the capability to underline and bold stuff, but
> have nil (display-graphic-p), right?  Is there a way to determine
> whether we're running on one of those terminals?  Because
> underlining/bolding is prettier than [t]his.

I don't think you should be bothered by that, because 'underline' is a
standard face, and every terminal expresses it as best as they can.
Just use it.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]