bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#18078: 24.4.50; flylisp lacks Package-Requires


From: Sebastian Wiesner
Subject: bug#18078: 24.4.50; flylisp lacks Package-Requires
Date: Thu, 31 Jul 2014 15:26:58 +0200

Am 30.07.2014 um 21:38 schrieb Barry OReilly <address@hidden>:

> > The Flylisp package in GNU ELPA [1] uses lexical binding and cl-lib,
> > but lacks a Package-Requires header with corresponding dependencies
> > on `(emacs "24.1")' and `(cl-lib "0.4")'.
> >
> > Without these dependencies, the package might accidentally be
> > installed on Emacs 23, which does not support lexical binding, and
> > it might fail to properly install on Emacs 24.1 and 24.2, which lack
> > cl-lib.
> >
> > Please add a Package-Requires header with appropriate dependencies.
> 
> I have done so, thanks.
> 

Thank you :)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]