bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#17358: 24.4.50; emacs not recognizing process-exit correctly?


From: T. V. Raman
Subject: bug#17358: 24.4.50; emacs not recognizing process-exit correctly?
Date: Sun, 27 Apr 2014 19:02:53 -0700

Has been happening for approximately a week or more -- and I
update from head almost everyday.  How exactly do I get a
non-glib emacs?
>>>>> "Daniel" == Daniel Colascione <address@hidden> writes:
    Daniel> On 04/27/2014 04:59 PM, T. V. Raman wrote:
    >> This has now happened to me with both mplayer and gpg, so
    >> I am beginning to suspect a bug in the process status
    >> handling code ...
    >> 
    >> Symptoms: Happens in long-running emacs sessions, and
    >> fails to repro if you kill and restart Emacs.
    Daniel> 
    Daniel> How long?
    Daniel> 
    >> When the bug bites,, emacs hangs waiting for the
    >> subprocess even though the subprocess has quit. Happens
    >> for example when you open a foo.gpg file. If this happens,
    >> the gpg process finishes decrypting the file, but Emacs
    >> fails to notice that it is done, and hangs. Hitting C-g
    >> produces the message "buffer *epg* has a running process
    >> ...". If you answer "no" to kill that process, emacs
    >> continues to hang. Checking status of the gpg process from
    >> a different terminal shows that process' status as
    >> "defunct".
    >> 
    >> Similar behavior with mplayer as well.
    >> 
    >> This is on an oldish Linux box that is still running
    >> Ubuntu Jaunty, but with updated libs for gnutls etc.
    Daniel> 
    Daniel> Just a hunch: can you try a non-glib Emacs?
    Daniel> 
    Daniel> application/pgp-signature [Press RETURN to save to a
    Daniel> file]





reply via email to

[Prev in Thread] Current Thread [Next in Thread]