bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16573: 24.3; Auctex (11.87.2) in Elpa issues hundreds of warnings on


From: Tassilo Horn
Subject: bug#16573: 24.3; Auctex (11.87.2) in Elpa issues hundreds of warnings on compile
Date: Fri, 31 Jan 2014 19:09:34 +0100
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.3.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

>> That's ok.  But if the style files were compiled, adding the requires
>> into the style files would make the compilation take minutes, because
>> each style file compilation would need to load the core files first.
>
> Yup.  I personally don't see much need to add the `require's in those
> style files.  Then again, I'm not too bothered by lingering warnings.

The problem is that the mass of warnings makes it hard to spot warnings
that are really defects.

However, now I've seen that adding requires to the style files doesnt't
help in the case where one style files uses vars/funs from another style
file (e.g., there's pstricks.el and several other sub-styles that use
funs/vars from the former, because they can assume that it's loaded
beforehand).  But style files can't be required cause they don't provide
a feature...

Bye,
Tassilo





reply via email to

[Prev in Thread] Current Thread [Next in Thread]