[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16553: 24.3.50; `file-truename' returns a cons? (wrong-type-argument

From: Drew Adams
Subject: bug#16553: 24.3.50; `file-truename' returns a cons? (wrong-type-argument stringp (...))
Date: Sat, 25 Jan 2014 15:09:11 -0800 (PST)

And in fact, if I do not redefine `describe-function-1', i.e., if I
evaluate the original definition, then I get the same error.

I did `debug-on-entry' for `help-fns--autoloaded-p' and then traced
things until the error was produced.  This is what I saw:

All of the calls to `file-truename' that I saw returned the right values.

There were multiple calls to `file-name-sans-extension', each of which,
except for the last, was passed an absolute file name and returned the
right value.  The last of these correct calls was this one:

Debugger entered--entering a function:

That returned, correctly,

(None of the calls involved file handlers or symlinks, FWIW.)

The next thing I saw in the debugger was this bizarre call to

Debugger entered--entering a function:
* file-name-sans-extension((require . fit-frame))
* #[514...]
* apply(#[514...] (message-tab 
* help-fns--autoloaded-p(message-tab 
  describe-key("        " 1 nil)
  call-interactively(describe-key nil nil)

That is, as soon as the previous call to file-name-sans-extension
returned, correctly (and I traced that call step by step, using `d'),
`d' in the debugger came up with what you see above.

I also tried `debug-on-entry' for `describe-function-1' (the vanilla
Emacs version) and then  `C-h f message-tab'.  Same thing.

My wild guess is that the problem comes somehow from using Cygwin (?).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]