bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16420:


From: Lars Andersen
Subject: bug#16420:
Date: Sun, 12 Jan 2014 19:27:07 +0100


The RES column does not grow.  I'm dual booting on that computer, so I tried reproducing the bug under Windows 7 without success.  

At this point is there anything to be learned from attaching GDB, or is this indeed someone else's problem at this point?  If I were to file this bug elsewhere, I'd be happy to get any pointers as to what information I should include in the report.

Lars

On Sun, Jan 12, 2014 at 7:08 PM, Jan Djärv <address@hidden> wrote:
Hello.

2014-01-12 18:26, Lars Andersen skrev:
(overlays-in (point-min) (point-max)) returns what you would expect:
#<overlay from 397 to 400 in *scratch*>

This was with a slightly altered example, I removed the overly long comment as
it took forever to draw.  100% cpu resources are used when the line is being
drawn, and it seems to be redrawn many times before it's finally done.  Then
all is well until something causes the line to be redrawn.

I'm not sure what 'RSS' means in this context, but I assumed you wanted a
screenshot of top:
http://imgur.com/Rv7Z5Ly

RSS is the RES column.  Does it grow?


Unfortunately emacs isn't shown here, but X always takes the blame for the
resource use, never emacs.  I have tried interrupting whatever is going on
with C-g after toggling debug-on-error, but I'm unable to interrupt anything
in this manner.

FWIW I cannot reproduce this bug on any other computers either.  My desktop
computer runs an almost identical software stack but is unaffected.

I will try to attach a debugger, but my computer is quite unusable after
triggering this problem, so it may be difficult.

This sounds like an X server bug.  As Emacs is not using much CPU it isn't inflooping and sending lots of X requests at least.

        Jan D.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]