[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15553: 24.3.50; epg.el and GnuPG 2.x cause unavoidable pinentry prom

From: Stefan Monnier
Subject: bug#15553: 24.3.50; epg.el and GnuPG 2.x cause unavoidable pinentry prompts for symmetrically encrypted files
Date: Wed, 09 Oct 2013 20:33:55 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

>>>> But it calls accept-process-output, so it can still get stuck.
>>> Yes, but it's not a hard lockup.  I can get out from the loop with C-g.
>> But if you have no terminal open (yet) on that emacs-server, you can't
>> hit C-g.
> Well, is that a realistic use case?  What do you suppose precisely?

> I thought that you meant like:
>   $ emacs -nw file.gpg
> or even
>   $ emacs -batch -l file.el.gpg

Sorry I didn't use the right terminology.  I meant an "emacs --daemon"
I.e. run an emacs process as a server and then connect to it via
emacsclient.  This server can sit in the background with no tty nor GUI
frame open anywhere.  If you then "emacsclient -eval <something>" and
this <something> involves opening a .gpg file you might get stuck with
an emacs server.  In any case, this is hypothetical.  I haven't even
tried it, and who knows maybe it does behave properly in the end
(e.g. gpg2 errors out because it can't find any X11 display nor any tty
to use to prompt the user).

So let's not worry about it too much until there's a concrete
problematic case.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]