bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14812: 24.3; build failure on FreeBSD 9.1


From: Wolfgang Jenkner
Subject: bug#14812: 24.3; build failure on FreeBSD 9.1
Date: Tue, 09 Jul 2013 16:04:23 +0200
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.3.50 (gnu/linux)

On Tue, Jul 09 2013, Ashish SHUKLA wrote:

> On Tue, 09 Jul 2013 02:40:06 -0400, Glenn Morris <address@hidden> said:
>> Ashish SHUKLA wrote:
>
>>> I'm the maintainer of editors/emacs* FreeBSD ports, and I'd couple of
>>> patches which are present in FreeBSD ports tree[1]. For this problem,
>>> I'm attaching the patches.
>>> 
>>> References:
>>> [1]  http://svnweb.freebsd.org/ports/head/editors/emacs-devel/files/
>
>> Most of those patches look more than 6 months old, which means they
>> predate Emacs 24.3. Had we been told about them, we could have fixed
>> Emacs 24.3 before it was released.

But the root problem is that emacs is compiled with -std=gnu99 and
FreeBSD therefore uses its own versions of _Alignas and friends because
of the following test in sys/cdefs.h:

#elif defined(__STDC_VERSION__) && __STDC_VERSION__ >= 201112L
/* Do nothing.  They are language keywords. */
#else
/* Not supported.  Implement them using our versions. */
#define _Alignas(x)             __aligned(x)

Unfortunately this doesn't work but I don't know if this is because of
the way emacs uses this stuff or because of a FreeBSD bug.

Wolfgang







reply via email to

[Prev in Thread] Current Thread [Next in Thread]