bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14765: 24.3.50; desktop-restore-frames on NS does not work


From: Juanma Barranquero
Subject: bug#14765: 24.3.50; desktop-restore-frames on NS does not work
Date: Tue, 2 Jul 2013 19:38:59 +0200

On Tue, Jul 2, 2013 at 7:34 PM, Jan Djärv <address@hidden> wrote:

> I get an error message:
>
> make-frame: Don't know how to interpret display ""zeplin.localhost""

Aha.

> In frame.el there is a check that the display matches entries in
> display-format-alist.  On NS that only contains "ns".  So there is
> a mismatch between what NS use for display name and what
> display-format-alist contains.  I will fix this in one way or another.
> NS does not have display names, or multiple displays so any
> display name should be OK.

Windows does not have display names either, so w32 functions that must
use or return a display name use "w32". I suggest you do the same and
use "ns" everywhere.

> The display-format-alist makes no sense.  It is not like we can
> start a W32 or NS frame on an X-verson of Emacs or have any
> combination except X on X, W32 on W32 and NS on NS.

There are X Server implementations for Windows. It could be
conceivable to have a Windows Emacs that could open "normal" (w32)
frames and X ones. It's just that nobody has implemented it.

Can we close this bug, then, or there's something more to do?

    J





reply via email to

[Prev in Thread] Current Thread [Next in Thread]