bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10996: 24.0.94; Splash screen causes first character to beep with em


From: Aaron Meurer
Subject: bug#10996: 24.0.94; Splash screen causes first character to beep with emacsclient
Date: Fri, 30 Mar 2012 16:00:38 -0600

On Wed, Mar 21, 2012 at 10:24 AM, Chong Yidong <address@hidden> wrote:
> Aaron Meurer <address@hidden> writes:
>
>> See the discussion at
>> http://lists.gnu.org/archive/html/help-gnu-emacs/2012-03/msg00079.html.
>> When starting emacsclient, sometimes, the first character I type would
>> not enter the character, but rather beep the screen.  I did a lot of
>> debugging of this, discovering that it does not happen with emacs -Q,
>> but removing all of my init files did not solve the problem.
>>
>> Finally, I discovered that the problem is the splash screen.  If I start
>> the emacs daemon with --no-splash, the problem goes away.  It appears
>> that somehow the splash screen is taking the first keypress from
>> emacsclient, even though the buffer that is visible is the one for the
>> file I opened.
>
> I'm afraid I can't reproduce it.  I tried:
>
> 1. touch .emacs    [empty .emacs file]
> 2. emacs --daemon
> 3. emacsclient -c
> 4. a
>
> The keystroke takes effect as expected.  Could you provide a recipe for
> showing the bug?
>

Maybe it matters that I start emacsclient with emacsclient -a "" -nw.

You can start the daemon with emacs -q --no-site-file --no-site-lisp
--daemon (basically, turn everything off except for the splash
screen).  If I do that, it reproduces nicely.  I'm assuming that the
above switches sufficiently isolate me from my configuration.

emacs --version gives me GNU Emacs 24.0.94.3 (this is probably also in
the original bug report generated by emacs.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]