bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10612: GnuTLS bundled with the windows Emacs binaries (was: bug#1021


From: Ted Zlatanov
Subject: bug#10612: GnuTLS bundled with the windows Emacs binaries (was: bug#10215: 24.0.92; Can't contact nnimap (gnutls-cli not found))
Date: Thu, 26 Jan 2012 09:44:03 -0600
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/24.0.92 (gnu/linux)

On Thu, 26 Jan 2012 01:04:25 +0100 Lars Ingebrigtsen <address@hidden> wrote: 

LI> Uwe Siart <address@hidden> writes:
>> Thanks a lot for pointing me to that and sorry for my stupidness. I
>> wasn't aware that additional software is necessary because it hasn't
>> been necessary for Emacs 23.3 (precompiled for Windows). More even I
>> wasn't aware that GnuTLS is available for Windows.

LI> Hopefully Emacs 24 will be distributed (for Windows) with the GnuTLS
LI> libraries included, so that this will just work out of the box.
LI> Otherwise I think there will be many similar bug reports.  :-)

Christoph has been doing that, I think, so we can rely on his binaries.

Christoph, can you add a GnuTLS build step to your Emacs build for
Windows, so the latest GnuTLS version can be used on that platform?  We
had a long conversation about this and at least for now it seems to be
the best approach (and we agreed it would not be a task for the core
Emacs developers).  If you prefer, I can set up a BuildBot to produce
the GnuTLS DLLs for you.

Ted






reply via email to

[Prev in Thread] Current Thread [Next in Thread]