[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9454: 24.0.50; thingatpt.el should be updated to respect field bound

From: Drew Adams
Subject: bug#9454: 24.0.50; thingatpt.el should be updated to respect field boundaries
Date: Tue, 6 Sep 2011 16:14:57 -0700

I'm no expert on fields, to put it mildly.  But my impression is that
thing-at-point functions should not cross field boundaries.
I ran into this using a thing-at-point function (actually, a
thing-near-point function) in the minibuffer.  Now that (forward-line 0)
takes you across the field boundary and into the prompt field, I ended
up with "Text is read-only" errors.
(And just why is it an improvement to have two fields here?  What was
wrong with the (simple) situation before?)
To fix this I ended up splattering my own thing-at-point code with
`constrain-to-field' calls.  Butt ugly, but unless I'm missing something
(quite possible), unavoidable.
Anyway, this is a heads-up that you might want to take a look at
thingatpt.el and DTRT wrt field boudaries.  FWIW, my own code is here:
http://www.emacswiki.org/emacs/download/thingatpt%2b.el.  Among other
things, it contains fixes for Emacs bugs #8667, #8628, and #9300 (fixes
already communicated, but still not applied to vanilla Emacs).

In GNU Emacs (i386-mingw-nt5.1.2600)
 of 2011-09-05 on 3249CTO
Windowing system distributor `Microsoft Corp.', version 5.1.2600
configured using `configure --with-gcc (4.5) --no-opt'

reply via email to

[Prev in Thread] Current Thread [Next in Thread]