bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#5885: [Aquamacs-bugs] Re: incorrect fontification of non-ascii chars


From: YAMAMOTO Mitsuharu
Subject: bug#5885: [Aquamacs-bugs] Re: incorrect fontification of non-ascii chars on Mac OS X 10.4
Date: Thu, 08 Apr 2010 16:59:52 -0000
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.6 (Marutamachi) APEL/10.6 Emacs/22.0.50 (sparc-sun-solaris2.8) MULE/5.0 (SAKAKI)

>>>>> On Fri, 24 Jun 2005 22:53:58 -0500, William Henney <address@hidden> said:

> Hi, Accented characters are not fontified correctly. For example, if
> I have '\emph{ojalá}' in a LaTeX file, then 'ojal' are displayed in
> an italic font but the 'á' is not. Same goes for bold, etc.

> This occurs both in Aquamacs and in regular Carbon Emacs.

I can't reproduce it either with fontset-mac (the default one) or with

  (create-fontset-from-mac-roman
   "-apple-monaco-medium-r-normal--14-*-*-*-*-*-mac-roman" nil "test1")
  (set-frame-font "fontset-test1")

while I can reproduce with

  (create-fontset-from-fontset-spec
   "-apple-monaco-medium-r-normal--14-*-*-*-*-*-fontset-test2,
    ascii:-apple-monaco-medium-r-normal--14-*-*-*-*-*-mac-roman,
    latin-iso8859-1:-apple-monaco-medium-r-normal--14-*-*-*-*-*-mac-roman")
  (set-frame-font "fontset-test2")

Aren't you using a fontset defined with
create-fontset-from-fontset-spec ?

Besides the above problem, I'd rather not recommend the use of
create-fontset-from-fontset-spec on Carbon Emacs because it introduces
tons of wrong glyphs.  For example, "×" is displayed as "W", "ý" as
"}", and so on.

                                     YAMAMOTO Mitsuharu
                                address@hidden








reply via email to

[Prev in Thread] Current Thread [Next in Thread]