bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3173: marked as done (Enabling gud-tooltip-mode in .emacs doesn't wo


From: Emacs bug Tracking System
Subject: bug#3173: marked as done (Enabling gud-tooltip-mode in .emacs doesn't work)
Date: Mon, 16 Nov 2009 20:00:29 +0000

Your message dated Mon, 16 Nov 2009 13:03:23 -0500
with message-id <address@hidden>
and subject line Re: Bug#3173: Enabling gud-tooltip-mode in .emacs doesn't work
has caused the Emacs bug report #3173,
regarding Enabling gud-tooltip-mode in .emacs doesn't work
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
3173: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3173
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Enabling gud-tooltip-mode in .emacs doesn't work Date: Thu, 30 Apr 2009 15:04:05 +0100 User-agent: Thunderbird 2.0.0.21 (X11/20090409)
To: address@hidden
Subject: Enabling gud-tooltip-mode in .emacs doesn't work
--text follows this line--

Please write in English if possible, because the Emacs maintainers
usually do not have translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list, and to the gnu.emacs.bug news group.

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

================
(This is pasted from Emacs into thunderbird since I don't have Emacs set up to send mail).

When running gdb under Emacs, M-x gud-tooltip-mode works fine with
tooltips appearing as the mouse is moved over variables.

With the following in the .emacs file:-


(custom-set-variables
  ;; custom-set-variables was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 '(gud-tooltip-mode t)
 '(inhibit-startup-screen t))

.....Emacs and gdb are then started but nothing happens when the mouse is moved over variables.

Doing M-x gud-tooltip-mode results in a message that tooltips are now
disabled implying that they were previously enabled and also that the
.emacs file was read correctly.

Doing M-x gud-tooltip-mode produces a mesasage that tooltips are
again enabled and this time the tooltips do appear with the mouse over
variables.

So it looks as if the .emacs file "half works" in that it enables the
mode but not the tooltips!

(I didn't turn off the startup file since it is part of the bug).

If there's anything else I can do to help please ask.

Richard Driscoll

=================

If Emacs crashed, and you have the Emacs process in the gdb debugger,
please include the output from the following gdb commands:
    `bt full' and `xbacktrace'.
If you would like to further debug the crash, please read the file
/usr/share/emacs/22.2/etc/DEBUG for instructions.


In GNU Emacs 22.2.1 (i486-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2008-09-05 on vernadsky, modified by Ubuntu
Windowing system distributor `The X.Org Foundation', version 11.0.10600000
configured using `configure '--build=i486-linux-gnu' '--host=i486-linux-gnu' '--prefix=/usr' '--sharedstatedir=/var/lib' '--libexecdir=/usr/lib' '--localstatedir=/var' '--infodir=/usr/share/info' '--mandir=/usr/share/man' '--with-pop=yes' '--enable-locallisppath=/etc/emacs22:/etc/emacs:/usr/local/share/emacs/22.2/site-lisp:/usr/local/share/emacs/site-lisp:/usr/share/emacs/22.2/site-lisp:/usr/share/emacs/site-lisp:/usr/share/emacs/22.2/leim' '--with-x=yes' '--with-x-toolkit=athena' '--with-toolkit-scroll-bars' 'build_alias=i486-linux-gnu' 'host_alias=i486-linux-gnu' 'CFLAGS=-DDEBIAN -DSITELOAD_PURESIZE_EXTRA=5000 -g -O2' 'LDFLAGS=-g -Wl,--as-needed' 'CPPFLAGS=''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: C
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_GB.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  which-function-mode: t
  show-paren-mode: t
  tooltip-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo>
<help-echo> <help-echo> <help-echo> <menu-bar> <help-menu>
<send-emacs-bug-report>

Recent messages:
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done
Loading debian-ispell...done
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done
Loading paren...done
Loading which-func...done
For information about GNU Emacs and the GNU system, type C-h C-a.
Loading emacsbug...
Loading regexp-opt...done
Loading emacsbug...done




--- End Message ---
--- Begin Message --- Subject: Re: Bug#3173: Enabling gud-tooltip-mode in .emacs doesn't work Date: Mon, 16 Nov 2009 13:03:23 -0500 User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)
gud-tooltip-mode autoloaded since Jun 21, 2009.


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]