[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#4832: emacs fails to open files

From: Glenn Linderman
Subject: bug#4832: emacs fails to open files
Date: Fri, 30 Oct 2009 00:19:03 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071030 a Firefox/ sibling, SeaMonkey/1.1.6 - see http://geckoisgecko.org Mnenhy/

Tried to open a file containing Romanian characters on Windows. The characters are â and ş . emacs 22.1.1. Tried a number of ways, particularly by using dired, and by dragging the file from Explorer to the emacs title bar (both of which work for other files). Also had problems with files containing Cyrillic characters in their names, or Chinese characters... those didn't even show up in dired!

Discovered that emacs 23.1 claims better Unicode support.  Yay!

And it might, but it doesn't solve this problem. Still couldn't drag the files into emacs 23.1. The Cyrillic and Chinese ones now show up in dired with shortnames! They can be opened, if you can guess which one to use. But the Romanian ones are still displayed with octal escapes in dired, and can't be opened from there or via dragging to the emacs title bar.

Seems likely the problem is related to the emacs file name handling probably using the "A" APIs for file names, instead of the "W" APIs.

Seems likely that this is still the same problem that was reported in the following thread from Aug 2004. And here it is Oct 2009!


I can't find out if there is an online emacs bug tracker, to know if the problem reported then is still in the queue, or if a workaround was posted, etc. Any help finding such a bug tracker would be appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]