bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#4712: File encoding


From: Eli Zaretskii
Subject: bug#4712: File encoding
Date: Thu, 15 Oct 2009 03:20:11 -0400

> From: Stefan Monnier <address@hidden>
> Cc: address@hidden,  address@hidden,  address@hidden
> Date: Wed, 14 Oct 2009 23:16:32 -0400
> 
> >> > Maybe so, but this part of the OP's report:
> >> 
> >> >   value of $LANG: en_AU.UTF-8
> >> >   locale-coding-system: utf-8
> >> 
> >> > indicates that UTF-8 is the "native" encoding on the OP's machine, and
> >> > there is an overwhelming user demand for silently and transparently
> >> > switch to such a native encoding when we need to select an encoding.
> >> 
> >> The `coding' cookie trumps any such setting, since when we read the
> >> file, we will blindly obey the cookie without paying any attention to
> >> the user's locale.
> 
> > Right, and we did:
> 
> >   Selected encoding mule-utf-8-unix disagrees with iso-8859-1-unix
> >   specified by file contents.
> 
> The fact that we even consider utf-8 is the bug, it means that the
> coding cookie didn't actually "trump" the locale setting.

Sigh...  In case it wasn't clear, I didn't mean to say this is not a
problem.  I tried to explain why it happens, so that someone who cares
could find the proper fix faster and without disrupting other
important features while at that.  But if no one wants to hear, I
guess I'll crawl back under my rock...





reply via email to

[Prev in Thread] Current Thread [Next in Thread]