bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#4614: 23.1.50; tramp-ftp-file-name-handler: Recursive `require' for


From: Stephen Berman
Subject: bug#4614: 23.1.50; tramp-ftp-file-name-handler: Recursive `require' for feature `ange-ftp'
Date: Sat, 03 Oct 2009 15:43:12 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.50 (gnu/linux)

On Sat, 03 Oct 2009 14:43:53 +0200 Michael Albinus <address@hidden> wrote:

> Glenn Morris <address@hidden> writes:
>
>> Stephen Berman wrote:
>>
>>> Until sometime within the last few weeks (sorry, I can't narrow it down
>>> more), the following (anonymized) code worked fine:
>>
>> Are you sure? It fails for me in the same way in both 22 and 23.1.
>> (It seems you can require ange-ftp beforehand as a workaround.)
>
> Indeed. I've fixed this in tramp-ftp.el. Stephen, could you please
> check, whether it works for you?

I haven't updated yet to get your change, but I confirm the workaround
works with emacs -Q on my current build.

However, I just tried the code again with my init file on my current
build and I cannot reproduce it now.  After my init file loaded, I did
`C-h v features' and found both ange-ftp and tramp-*, which would
explain why it works.  I don't know why it didn't work when I reported
it (with the same initializations), but that failure happened in several
separate Emacs sessions, on at least two different days.  Perhaps I
loaded some function that unloaded ange-ftp, ...or it's a heisenbug.
Anyway, I'll update and try your fix, Michael.  You can wait till I
confirm it works to close the bug, but that might not be till tomorrow.
But since it appears to be unreproducible, it's probably ok to close it
now.

Steve Berman





reply via email to

[Prev in Thread] Current Thread [Next in Thread]