[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3053: "emacsclient -a emacs" produces "No server editing

From: 韓達耐
Subject: bug#3053: "emacsclient -a emacs" produces "No server editing
Date: Sat, 25 Apr 2009 02:08:39 +0200

Hi Stefan

I have compiled "EMACS_PRETEST_23_0_92.tar.gz" and tried the following command:

[2009-04-25 02:01:27] address@hidden:/usr/src/EMACS_PRETEST_23_0_92/lib-src
  $ ./emacsclient -a "../src/emacs" ../Makefile
./emacsclient: can't find socket; have you started the server?
To start the server in Emacs, type "M-x server-start".

Now a new Emacs instance is started, and my own ~/.emacs is loaded
which includes "(server-start)".

When I close the "Makefile" buffer with "C-x #" I still get the same
message: "No server editing buffers exist".

In other words: when emacsclient fails to load because there is no
server running, it will launch "../src/emacs ../Makefile".  What I
would like to see instead, is that it will launch "../src/emacs"
first, and then try "emacsclient ../Makefile" again.  This behaviour
seems more logical to me.

Best regards


reply via email to

[Prev in Thread] Current Thread [Next in Thread]