[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Configure/compile failure on Solaris 10 Sparc Ultra 25

From: Glenn Morris
Subject: Re: Configure/compile failure on Solaris 10 Sparc Ultra 25
Date: Sun, 15 Apr 2007 19:55:49 -0400
User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)

"Glasser, Nathan" wrote:

> I tried to build Emacs-21.4a (emacs-version says 21.4.1) on Solaris 10
> The compiler is "Sun WorkShop 6 update 2 C 5.3 2001/05/15".
> When I run configure, configure runs cpp to test for various header
> files being present, and other things. However, these often got
> errors, because the symbol "__sparc", which would normally be
> defined if cc was run, was not defined, and lots of system header
> files depended on it.
> echo '#define __sparc 1' > confdefs.h
> A better fix might be to use "cc -E" rather than cpp; I tried this
>and the symbol is defined using the former, but not the latter. I
>can't tell you why this used to work in the past, but in my current
>setup it does not.

I'm a bit confused. Are you saying it does _not_ work if you use "cc
-E" as the preprocessor? Does it work if you use "cc -E -Xs", making
sure the "cc" is the same one as your compiler?

We hope to release Emacs 22 soon, and it would be helpful if you
could see if that works for you. The latest pretest version at present
is 22.0.97, which you can get from alpha.gnu.org/gnu/emacs/pretest.

I just succesfully built this version on Solaris 10. The closest
compiler I could find to yours was: "Sun WorkShop 6 update 1 C 5.2
2000/09/11". I configured using:

env CC=/path/to/cc CPP="/path/to/cc -E -Xs" ./configure

If it does not work, please give more detail as to exactly what you
tried and what the result was.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]