bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs crashing with rmail


From: Art Werschulz
Subject: emacs crashing with rmail
Date: Tue, 26 Apr 2005 11:09:10 -0400

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2005-02-04 on bugs.build.redhat.com
configured using `configure  --build=i386-redhat-linux --host=i386-redhat-linux 
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr 
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc 
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib 
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com 
--mandir=/usr/share/man --infodir=/usr/share/info --with-pop --with-sound'
Important settings:
  value of $LC_ALL: C
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

When I type M-x rmail, emacs crashes.

Here is more information:

As of about a week ago, the command "M-x rmail" causes emacs to crash,
producing the error msg
        Fatal error (6).Aborted (core dumped)
Prior to that time, this command worked fine.

The gdb backtrace on the core file is as follows:
  #0  0x00bdf7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
  #1  0x00c20c76 in kill () from /lib/tls/libc.so.6
  #2  0x080db899 in abort ()
  #3  <signal handler called>
  #4  0x00bdf7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
  #5  0x00c20c76 in kill () from /lib/tls/libc.so.6
  #6  0x080db3ea in abort ()
  #7  0x08128b2f in re_compile_pattern ()
  #8  0x08123e24 in re_compile_pattern ()
  #9  0x08123e48 in re_compile_pattern ()
  #10 0x0808e6c3 in ?? ()
  #11 0xffffffff in ?? ()
  #12 0xbfffe570 in ?? ()
  #13 0x00000000 in ?? ()

Here are some data points:

(1) This only happens to me.  Other people can read mail with emacs without
    any problems.

(2) This behavior persists even if I rename my RMAIL file (so RMAIL file
    corruption doesn't appear to be an issue).

(3) This behavior persists even if I use the -q, -u, or --no-site-file
    command line options.

(4) I tried this on several machines on our network; this behavior occurs
    on all the machines I tested.

(5) I can visit the RMAIL file (using C-x C-f RMAIL), after which I can
    run commands to delete messages, reply to messages and the like.
    However, if I issue the rmail-get-new-mail command (bound to the "g"
    key in RMAIL mode), emacs crashes.

Thanks.

Recent input:
<escape> x r e p o r t - e m a c s - b u g <return
>

Recent messages:
Setting up cedet-contrib...done
Loading semantic-decorate-mode...done
Loading senator...
Loading ring...done
Loading senator...done
Loading mwheel...done
Loading two-column...done
Loading semantic-el...done
For information about the GNU Project and its goals, type C-_ C-p.
Loading emacsbug...done




reply via email to

[Prev in Thread] Current Thread [Next in Thread]