bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

command fill-paragraph deletes leading Umlauts if line begins with space


From: Ulrich Scholz
Subject: command fill-paragraph deletes leading Umlauts if line begins with space
Date: Wed, 22 Dec 2004 19:29:44 +0100
User-agent: SEMI/1.14.6 (Maruoka) FLIM/1.14.6 (Marutamachi) APEL/10.6 Emacs/21.3 (i386-pc-linux-gnu) (with unibyte mode)

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2004-10-16 on raven, modified by Debian
configured using `configure '--build=i386-linux' '--host=i386-linux' 
'--prefix=/usr' '--sharedstatedir=/var/lib' '--libexecdir=/usr/lib' 
'--localstatedir=/var/lib' '--infodir=/usr/share/info' 
'--mandir=/usr/share/man' '--with-pop=yes' '--with-x=yes' 
'--with-x-toolkit=athena' 'CFLAGS=-DDEBIAN -g -O2' 'build_alias=i386-linux' 
'host_alias=i386-linux''
Important settings:
  value of $LC_ALL: C
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.ISO-8859-15
  locale-coding-system: nil
  default-enable-multibyte-characters: nil

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

The command changes the following paragraph

 �bersetzung L�sungsverfahren f�r eine spezielle Problemdom�ne haben auch
Probleme:

to the paragraph

bersetzung L�sungsverfahren f�r eine spezielle Problemdom�ne haben
auch Probleme:

Note that the � of �bersetzung is missing in the second version.  The
bug eats any number of Umlauts, but only as first characters of the line after
some spaces.  Umlauts after the first non-Umlaut or in lines that begin with a
non-space remain.

I don't know how to get a list of all active modes.  The bug occurs while
editing an LaTeX-file.  I use auc-tex and reftex.  iso-accents-mode does not
seem to cause the bug.



Recent input:
<mouse-movement> <mouse-movement> <mouse-movement> 
<mouse-movement> <mouse-movement> <mouse-movement> 
<mouse-movement> <mouse-movement> <mouse-movement> 
<mouse-movement> <mouse-movement> <mouse-movement> 
<mouse-movement> <drag-mouse-1> <help-echo> <down-mouse-1> 
<mouse-1> <down-mouse-2> <mouse-2> <help-echo> e <return> 
<help-echo> <down-mouse-1> <mouse-1> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> C-x 3 C-x 4 4 C-x 4 <down-mouse-1> 
<mouse-1> <menu-bar> <buffer> "projekt_leanplan.tex" 
<help-echo> <down> <down> <down> <down> <down> <down> 
<down> <up> <return> <return> <return> <up> <up> SPC 
" U b e r f a l l M-q <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <menu-bar> <help-menu> 
<report-emacs-bug>

Recent messages:
Making completion list... [4 times]
isearch-abort: Quit
call-interactively: Quit
Making completion list...
call-interactively: Command attempted to use minibuffer while in minibuffer
Wrote /home/scholzuh/bug.txt
Type C-c C-x C-z to exit MIME mode, and type C-c C-x ? to get help.
Fontifying *mail*... (regexps........)
Type C-c C-x C-z to exit MIME mode, and type C-c C-x ? to get help.
Auto-saving...done




reply via email to

[Prev in Thread] Current Thread [Next in Thread]