bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug for Emacs


From: Adam Cohen
Subject: Re: Bug for Emacs
Date: Wed, 22 Dec 2004 02:40:09 -0500

This exact same issue has already been discussed.  Searching for
"configure: error: Emacs hasn't been ported to
`powerpc-apple-darwin7.7.0' systems." on google turns up this:

http://lists.gnu.org/archive/html/bug-gnu-emacs/2004-12/msg00106.html

To compile on OS X, you need the cvs source from here:

cvs -z3 -d:ext:address@hidden:/cvsroot/emacs co emacs

Although you're right, in the list of supported platforms, it should
probably be noted that OS X support requires the cvs version of emacs.

As for the version of emacs showing up as powerpc-apple-darwin7.0
while the newly downloaded versions display an error message for
powerpc-apple-darwin7.7.0, the reason for this is because the copy of
emacs 21.2.1 that came preinstalled on your Mac was built against
Darwin 7.0, which corresponds to 10.3.0.  Similarly, Darwin 7.7
corresponds to OS X 10.3.7 which is what you're currently using.

And regarding not being able to create separate frames, it doesn't
work for me either, but it does work in the fink version of emacs
(21.3.50.1).  If you haven't yet heard of fink, you should definitely
check it out, since it provides an easy to use package manager for
downloading and installing prebuilt (and source) versions of many
popular packages (including emacs with X11 support).  The web site is:
<http://fink.sourceforge.net>.

Also, there's a carbon version of emacs available, which provides a
native aqua interface, available from here:
<http://members.shaw.ca/akochoi-emacs/>.

Adam



On Tue, 21 Dec 2004 20:09:56 -0800, Pearson, Sean <address@hidden> wrote:
>  
> 
> I have what I think is a bug to report.
>  
>  I have emacs-21.2.1 running on Max OSX 10.3.7.  However, before I realized
> this, I tried to download emacs from ftp.gnu.org, and also ftp.kernel.org. 
> From kernel .org, I believe I downloaded 21.1 by mistake, and tried to
> configure it by typing
>       ./configure
>  which failed with the following message:
>  
>  loading cache ./config.cache
>  checking host system type... powerpc-apple-darwin7.7.0
>  configure: error: Emacs hasn't been ported to `powerpc-apple-darwin7.7.0'
> systems.
>  Check `etc/MACHINES' for recognized configuration names.
>  
>  I then downloaded emacs-21.3 from ftp.gnu.org, with a similar result.  Now,
> on the web at
>       <http://www.gnu.org/software/emacs/emacs.html#Platforms>
>  the operating system Mac-OS X is listed as an OS which Emacs 21 runs on
> regardless of machine type.  Clearly, I do have emacs running on my machine,
> so it does work.  Then, there must be a problem with the configure script,
> or something related to it.  By the way, when I run emacs, on my machine, I
> get the following in the initial buffer:
>  
>  Welcome to GNU Emacs
>  
>  Get help           C-h  (Hold down CTRL and press h)
>  Undo changes       C-x u       Exit Emacs               C-x C-c
>  Get a tutorial     C-h t       Use Info to read docs    C-h i
>  Ordering manuals   C-h RET
>  Activate menubar   F10  or  ESC `  or   M-`
>  (`C-' means use the CTRL key.  `M-' means use the Meta (or Alt) key.
>  If you have no Meta key, you may instead type ESC followed by the
> character.)
>  
>  GNU Emacs 21.2.1 (powerpc-apple-darwin7.0)
>   of 1976-04-01 on localhost
>  Copyright (C) 2001 Free Software Foundation, Inc.
>  
>  GNU Emacs comes with ABSOLUTELY NO WARRANTY; type C-h C-w for full details.
>  Emacs is Free Software--Free as in Freedom--so you can redistribute copies
>  of Emacs and modify it; type C-h C-c to see the conditions.
>  Type C-h C-d for information on getting the latest version.
>  
>  It appears that my copy of emacs recognizes a different version of the OS
> or hardware than do the copies I downloaded.
>  
>  Also, I am unclear on something.  I have been using emacs on my Redhat
> system, and a port on WinXP.  Both of those support multiple frames. 
> However, when I typed C-x 5 2 on my copy of emacs, it did nothing, or else
> it blinked, but I don't see a new top-level window.  If this is because it
> is running in terminal mode, that I understand.  However, I can't seem to
> get a copy of emacs running NOT in terminal mode, and I think that if this
> is impossible, that should be explained somewhere.
>  
>  Please get back to me about this.
>  
>  Sean Pearson
>  address@hidden
>  
>  
> _______________________________________________
> Bug-gnu-emacs mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/bug-gnu-emacs
> 
> 
>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]