bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

file-symlink-p gives wrong name when target has a colon


From: Bill Lytton
Subject: file-symlink-p gives wrong name when target has a colon
Date: Sat, 27 Nov 2004 12:28:35 -0500

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2003-05-22 on porky.devel.redhat.com
configured using `configure  --host=i386-redhat-linux --build=i386-redhat-linux 
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr 
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc 
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib 
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com 
--mandir=/usr/share/man --infodir=/usr/share/info --with-gcc --with-pop 
--with-sound'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

If I link to a filename with a colon in it; eg

el% touch /tmp/aa:aa
el% ln -s /tmp/aa:aa /tmp/bb
el% ls -l /tmp/bb
lrwxrwxrwx    1 billl    billl          10 Nov 27 12:23 /tmp/bb -> /tmp/aa:aa

file-symlink-p mysteriously appends '/:'

ELISP> (file-symlink-p "/tmp/bb")
"/:/tmp/aa:aa"

Recent input:


Recent messages:
Composing main Info directory...
Mark set
Composing main Info directory...done
Mark saved where search started
Mark set [5 times]
History item: 1
Mark set
nil
Not found
Loading emacsbug...done




reply via email to

[Prev in Thread] Current Thread [Next in Thread]