bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RMAIL can only use one POP password even with multiple accounts


From: Bijan Soleymani
Subject: RMAIL can only use one POP password even with multiple accounts
Date: Wed, 02 Apr 2003 15:15:20 -0500

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.2.2 (i386-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2003-02-12 on raven, modified by Debian
configured using `configure  i386-linux --prefix=/usr --sharedstatedir=/var/lib 
--libexecdir=/usr/lib --localstatedir=/var/lib --infodir=/usr/share/info 
--mandir=/usr/share/man --with-pop=yes --with-x=yes --with-x-toolkit=athena 
--without-gif'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I use two different POP accounts for my email (sometimes I even use a
third account as well). I specify my accounts in the list
rmail-primary-inbox-list:
(setq rmail-primary-inbox-list '("po:address@hidden:pop.psq.com"
                                 "po:address@hidden:mail.crasseux.com"))

Then I set the variable rmail-pop-password-required to t so that rmail
will ask me for my password:
(setq rmail-pop-password-required t)

Finally I run M-x rmail

Then I am prompted for a password. I enter the password for my first
account, rmail then says it's gettign my mail from the server but then
it says that the authentication failed. However if I only specify one
of my two POP accounts in rmail-primary-inbox-list then I get my
emails without a problem.

This shouldn't be that difficult to fix. Simply use one password for
each pop account.

Or prompt the user with something like:
password for address@hidden:
password for address@hidden:

Thanks in advance,
Bijan Soleymani

Recent input:
ESC x e m TAB a TAB r e TAB p TAB DEL DEL DEL DEL DEL 
DEL DEL DEL DEL DEL r e p o TAB r t TAB RET

Recent messages:
Loading /home/bijan/programs/elisp/insert-yow.elc...done
Loading /home/bijan/programs/elisp/rot13-text.elc...done
Loading /home/bijan/programs/elisp/insert-date.elc...done
Loading /home/bijan/programs/elisp/eplay.el (source)...done
For information about the GNU Project and its goals, type C-h C-p.
Making completion list...
Loading view...done
call-interactively: Text is read-only
Making completion list...
Loading emacsbug...done




reply via email to

[Prev in Thread] Current Thread [Next in Thread]