bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Documentation Errata in Info nodes for info -- Emacs 21.2


From: Robert Spector
Subject: Documentation Errata in Info nodes for info -- Emacs 21.2
Date: Mon, 22 Apr 2002 06:21:39 -0400

To: address@hidden
Subject: Documentation bugs in Info pp.
--text follows this line--
This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.2.1 (i386-msvc-nt5.0.2195)
 of 2002-03-19 on buffy
configured using `configure --with-msvc (12.00)'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: ENU
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:
========================================================================
Info nodes (file info) contains some errata that mar its outstanding quality:


Help-^L node second sentence: "The node's title is underlined; ..." is false,
at least in my configuration.


Help-^L node, bottom half, has "Then come back, with <SPS>s." Should be "<SPC>s"


Node "Expert" has title "Advanced Info Commands" but node "Advanced Info" has
title "Info for Experts";
the former is the child (menu choice) of the latter.  Node "Top" has child
"Advanced Info" but the text
of "Top" refers to the menu item by its (hidden, and incorrect) title "Advanced
Info".


The <SPC> and <DEL> keys behave very differently in the "Index" node, where they
jump directly (like a
cross-reference or menu jump).  In that node, only C-v and M-v can be used
(apparently).


The <SPC> and <DEL> keys behave differently also when a menu is visible.  They
treat the line

* Menu:

as the de-facto end of the node.  <SPC> proceeds to the first sub-node (first
menu item), and <DEL>
returns to the `* Menu:' line, rether than the true end of the node.  This is
problematic especially
in the "Help-M" node written for the novice, which does not warn the reader
about this behaviour
when urging him: "Now use <SPC> to find the menu in this node, ...".


Node "Help-M" contains the example:

     * Foo:  Node about FOO      This tells about FOO

which is not obviously well-formed... the node name is missing a trailing `.'
(and it
is only much later, in node "Menus", that mention is made of terminating w/a
<TAB>, `,',
or <RET>, and there it is not clear if this terminator is translated into a
canonical
form of `.' or not, when the entry is finally rendered on the screen).
Moreover,
the paragraph preceeding this line contains a discussion which fails to mention
the presence of any terminating delimiter for the node's name (although the real
menu items later in the node do contain a `.')

Node "Help-Int" has the typo "..., ad `l' command...", ("ad" should be "an").

Node "Help-Q" has the typo "We urge you to make learn..." (remove the word
"make")

Advancing from node "Help-Q" to node "Advanced Info" and then returning works
with ] and [,
and with <SPC> and <DEL>, but fails with <SPC> and `l' (which brings it first to
the end
of the "Getting Started" Node (parent node of "Help-Q").  Perhaps this is a
general feature
of the Info reader built into emacs, not specific to the aforementioned nodes?

Node "Advanced Info" states "... writing a Texinfo file is better, ..." giving
two reasons
but failing to mention that it can also be used to generate HTML.  Same comment
applies to
the first paragraph of the "Add" node.

Node "Add" incorrectly states "As you can see, this node's `Up' node is the node
`Top', ..."
when in fact `Up' points to "Advanced Info" node.

========================================================================
Recent input:
<down-mouse-1> <mouse-1> <down-mouse-1> <mouse-1> <help-echo>
<down-mouse-1> <mouse-1> <help-echo> <down-mouse-1>
<mouse-1> <down-mouse-1> <mouse-1> <down-mouse-1> <mouse-1>
<down-mouse-1> <mouse-1> <help-echo> <help-echo> <help-echo>
<down-mouse-1> <mouse-1> <help-echo> <down-mouse-1>
<mouse-1> <help-echo> <down-mouse-1> <mouse-1> <down-mouse-2>
<mouse-2> h n <help-echo> <down-mouse-1> <mouse-1>
<down-mouse-1> <mouse-1> SPC <backspace> n n <help-echo>
<help-echo> <down-mouse-1> <mouse-1> <down-mouse-1>
<mouse-1> <help-echo> <down-mouse-1> <mouse-1> <down-mouse-1>
<mouse-1> <down-mouse-1> <mouse-1> n <help-echo> <down>
<down> <down> <down> <down> <down> <down> <down> <down>
<down> <down> <down> SPC <backspace> <backspace> <backspace>
SPC SPC SPC <backspace> <backspace> SPC SPC <backspace>
SPC <backspace> <prior> <prior> <prior> <prior> <next>
<next> <next> <next> <next> <prior> C-l b C-l <next>
<down-mouse-1> <mouse-1> <menu-bar> <help-menu> <r
eport-emacs-bug>

Recent messages:
Composing main Info directory...
Mark set
Composing main Info directory...done
mouse-drag-header-line: Cannot move header-line at the top of the frame [2
times]
Loading emacsbug...done
Auto-saving...done
Info-extract-pointer: Node has no Previous [2 times]
call-interactively: Beginning of buffer [4 times]
call-interactively: End of buffer [4 times]
Mark set





reply via email to

[Prev in Thread] Current Thread [Next in Thread]