bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug#142608: emacs21: please apply flyspell patch from preview-latex


From: David Kastrup
Subject: Re: Bug#142608: emacs21: please apply flyspell patch from preview-latex package
Date: 14 Apr 2002 12:28:22 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2.50

I have now checked the patch from Emacs-21.1 to Emacs-21.2.  The fixes
are not contained in Emacs-21.2, so it seems they would have been
judged not important enough for the bug fix release 21.2, which I find
unfortunate.  The bugs are not present in the current CVS version,
however, so it may be hoped that they will not make it into 21.3.  As
the main author of preview-latex, and the author of these patches, I
would recommend applying them at the very least when you are
installing preview-latex.  They are rather certainly not causing more
trouble than the original behavior.  They have been tested, and either
they. or equivalent changes, have been put into the current Emacs
sources long ago.

The bugs will affect every package using overlays with keymaps of
their own, not just preview-latex.  I don't know, however, whether
there are packages around where the impact is as annoying as here.

address@hidden (Rob Browning) writes:

> A recent report suggests Emacs 21.2 may have a bug which interacts
> with the preview-latex package.  I've included the two Emacs patches
> provided by the preview-latex source below in case you haven't
> received them yet through other channels.
> 
> Please let me know if you'd like me to include these patches in the
> current Debian Emacs 21.2 package.

I will update preview-latex documentation to state that those bugs
remain in Emacs-21.2.  Pity.

-- 
David Kastrup, Kriemhildstr. 15, 44793 Bochum
Email: address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]