[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug: emacs 21.1 build failure

From: Nicholas J. Kain
Subject: bug: emacs 21.1 build failure
Date: Wed, 31 Oct 2001 14:30:25 -0500
User-agent: Mutt/1.2.5i

When trying to build emacs 21.1 (umodified, downloaded from ftp.gnu.org), I
consistently have the build fail with the error:


Loading float-sup...
((40609 . 4242) (8109 . 0) (511 . 43) 70097 105505 (14 . 9) (21 . 0) (7042 . 
Loading vc-hooks...
Loading ediff-hook...
((41561 . 3290) (8193 . 0) (512 . 42) 71041 105521 (14 . 9) (21 . 0) (7102 . 
Finding pointers to doc strings...
Opening doc string file: no such file or directory, ../ews keeps 
make[1]: *** [emacs] Error 255
make[1]: Leaving directory `/home/njk/install/emacs-21.1/src'
make: *** [src] Error 2


To me, it appears that the text "ews keeps th" or "ws keeps the" is being
inserted into what should be "../etc/DOC-21.1.1".  This text would appear to
come from lisp/window.el line 206 or the compiled result window.elc.

The problem appears to happen in lisp/loadup.el, with the failing line being
line 227.  Unfortunately, my knowledge of elisp is lacking and I have been
unable to pinpoint the cause of the problem, despite some attempt.

Suspecting that my build process is producting a corrupt temacs, I have tried
various compiler optimization settings, including -O2, -O3, -O3 -s
-mcpu=k6 to no avail.  I have upgraded both kernel and binutils to the latest
versions with no success.

configure command lines tried:

./configure --without-xim --with-x-toolkit=motif

Method of reproduction:

tar xvfz emacs-21.1.tar.gz
cd emacs-21.1

System specs:

This system is quite reliable, and I would tend not to suspect hardware
failure.  The gnu/linux system on it is older than the hardware and has been
set up and reliable under heavy use for about a year.

handbuilt gnu/linux system

kernel:                 Linux 2.4.13-ac5
cc:                     gcc 2.95.2
libc:                   glibc 2.1.3

Hardware specs:

processor:              Athlon 1.33GHz running at 1.33GHz
memory:                 512MB registered ECC
motherboard:            MSI K7 Master: AMD761 northbridge, VIA686B southbridge

Nicholas Kain <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]