[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-GIFT] GIFT installation problem on 64 bit machine.

From: Henning Müller
Subject: Re: [bug-GIFT] GIFT installation problem on 64 bit machine.
Date: Fri, 26 Feb 2010 18:46:39 +0100
User-agent: Thunderbird (Macintosh/20090812)


have you tried the latest version from the SVN?
Maybe this could work.

Cheers, Henning

Cation Anion wrote:
Hi, I am new to GIFT. I am facing trouble with the installation on a 64 bit machine.

The following is the error while doing make:
CAFPerl.cc: In member function 'virtual CAccessor* CAFPerl::makeAccessor(const CXMLElement&) const':
CAFPerl.cc:8: error: cannot allocate an object of abstract type 'CAcPerl'
../../libGIFTAcPerl/include/CAcPerl.h:72: note: because the following virtual functions are pure within 'CAcPerl': ../../libMRML/include/CAccessor.h:109: note: virtual void CAccessor::getRandomIDs(std::list<long int, std::allocator<long int> >&, size_t) const ../../libMRML/include/CAccessor.h:119: note: virtual void CAccessor::getRandomAccessorElements(std::list<CAccessorElement, std::allocator<CAccessorElement> >&, size_t) const

These are the specs:
Red Hat Enterprise 4.1.2-46
Intel Xeon 2GHz

Did someone else experience this issue ? Is there a fix ? I tried installing different version of GIFT (0.1.13 and 0.1.14) but end up with same (above) problem.



bug-GIFT mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]