[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gettext] msgfmt segfault under qemu-arm, Jessie only

From: Daiki Ueno
Subject: Re: [bug-gettext] msgfmt segfault under qemu-arm, Jessie only
Date: Fri, 01 May 2015 11:22:55 +0900
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.4 (gnu/linux)

John Morris <address@hidden> writes:

> The `msgfmt` executable segfaults  only under `qemu` (`armhf`; other
> arches untested) and only in Debian Jessie (package v. 0.19.3-2).
>     # schroot -u root -c jessie-armhf-sbuild -- \
>         qemu-arm-static /usr/bin/msgfmt
>     qemu: uncaught target signal 11 (Segmentation fault) - core dumped
>     E: Child terminated by signal ‘Segmentation fault’
> The same thing works fine in Ubuntu Trusty, so my first thought was to
> rebuild that package v. for Jessie.  However, that
> version segfaults, too.  So, apparently not a regression in `gettext`.
> I also tried attaching a debugger, remotely, as required by `qemu`,
> but this didn't work well; log below.  Maybe it's qemu that's
> crashing.

If qemu itself is crasing, I'm afraid I doubt we can do much about it.

> At least one other person has run across the `msgfmt`/`qemu`
> problem. He believes it's due to `pthreads`, but if so I'm surprised
> not many more have encountered it.  Link:
>     http://samnazarko.co.uk/2014/07/git-under-arm-emulated-environments/

For what it's worth, I tried to reproduce it using armhf toolchain from
emdebian.  The test case attached to the bug[1] (linked from the blog)
indeed crashes qemu, but I can't reproduce it with msgfmt.  The
procedure I followed is:

- cross-compile pristine gettext 0.19.4 with:

  $ ./configure --host=arm-linux-gnueabihf \
                --build=`build-aux/config.guess` \
                --prefix=/usr/arm-linux-gnueabihf \
                CFLAGS="-g3 -O0 -Wall" CXXFLAGS="-g3 -O0 -Wall"
  $ make && make install

- run it with qemu-arm-static

  $ qemu-arm-static -L /usr/arm-linux-gnueabihf \
  /usr/arm-linux-gnueabihf/bin/msgfmt: no input file given
  Try '/usr/arm-linux-gnueabihf/bin/msgfmt --help' for more information.
  zsh: exit 1

> Have list members encountered this before?  Any advice on where to
> start digging next?  Thanks-

There are many possibilities causing the difference, but I suspect this
might be caused by the dependencies (e.g. libxml2, libcroco, glib2,
...) which are not installed on my setup.

[1]  https://bugs.launchpad.net/qemu/+bug/1098729

Daiki Ueno

reply via email to

[Prev in Thread] Current Thread [Next in Thread]