[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gettext] Cross compiling gettext 0.19 for Windows 64 bit result

From: Michele Locati
Subject: Re: [bug-gettext] Cross compiling gettext 0.19 for Windows 64 bit results in libwinpthread-1.dll not found error
Date: Wed, 4 Jun 2014 10:08:42 +0200

It's quite strange: when I compiled 0.18.3 I had no such problems. Maybe I'll try an older version of debian and/or ubuntu.
BTW, I just released the new Windows binaries (see http://mlocati.github.io/gettext-iconv-windows )

Thank you

2014-06-04 1:45 GMT+02:00 Daiki Ueno <address@hidden>:
Michele Locati <address@hidden> writes:

> I run the script attached to this message.

Thanks for the script.  I've just tried it (on Debian, though) and
reproduced the problem, while it also happens with gettext-

> Everything compiles as expected, but when I launch the gettext
> programs (eg xgettext.exe) under Windows I get the error message
> that libwinpthread-1.dll can't be found.

With objdump -x msginit.exe, I got:

        DLL Name: libwinpthread-1.dll
        vma:  Hint/Ord Member-Name Bound-To
        102a0      70  pthread_mutex_init
        102b8      71  pthread_mutex_lock
        102d0      74  pthread_mutex_unlock
        102e8      75  pthread_mutexattr_destroy
        10304      80  pthread_mutexattr_init
        10320      84  pthread_mutexattr_settype

So I searched on the web and found this thread:

  [Mingw-w64-public] Getting Rid of winpthread Dynamic Dependency

It seems to be unavoidable as long as the mingw-w64 gcc depends on
libwinpthread-1.dll.  Are you able to work this around by just copying
the DLL to bin/?

Daiki Ueno

reply via email to

[Prev in Thread] Current Thread [Next in Thread]