[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: updatedb not working

From: James Youngman
Subject: Re: updatedb not working
Date: Sun, 31 Oct 2004 13:05:41 +0000
User-agent: Mutt/1.3.28i

On Sat, Oct 30, 2004 at 03:58:40PM -0500, Wesley T. Barrett wrote:
> For the past 8 days now apparently updatedb has been broken. I just 
> found out when I logged in today and tried to do a locate. It warned me 
> that locatedb was at least 8 days old. I tried to do an updatedb and 
> received the following error message
> /usr/bin/find: . changed during execution of /usr/bin/find

I have now released findutils-4.2.3; you can download this from
ftp://alpha.gnu.org/gnu/findutils.  It issues a more useful error
message in this case, in order to help solve this problem.  

The error message indicates
        1. The type of filesystem where the problem is appearing
        2. The inode number of the directory that find expected to chdir to
        3. The inode number of the directory that find did chdir to

If you get the error message again, please figure out which
directories are involved.  You can do this with (for example) "ls -iR"
or "find . -inum XYZ -print -quit" (the -quit option is a new feature
in findutils 4.2.3).  

The thing that normally causes the problem you are seeing is
directories being moved from one place to another while find is
searching them.  Once you know which directory is affected, please
check to see if this actually happens on your system.

Please let me know what you find.

> When I finally exit back to command line (it won't do this on its own) I 
> get this message:
> updatedb: new database would be empty
> And of course I am still unable to use locate :). 

If you see that message, your old locate database should remain in
place.  That means that locate should be usable (though with out of
date data) unless updatedb has *never* worked on your system.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]