[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-ddrescue] What am I doing wrong? ddrescue: cannot open output file:

From: televiseus
Subject: [Bug-ddrescue] What am I doing wrong? ddrescue: cannot open output file: not a directory
Date: Wed, 10 Oct 2007 11:01:03 -0700 (PDT)


I had my windows C drive stop booting and have been trying to run ddrescue
on it to get as much off it as possible. Despite being a total noob to linux
and thanks to the helpful posts on this mailing list and some research I've
been able to do these things so far:

I found ddrescue 1.5 and some other useful on a Parted Magic Live CD.

I booted with the live cd and partitioned the 300gb usb hdrive i want the
ddrescue outfile to go to. It now has 3 ntfs partitions (sda1 is the
original resized partition that was on the external and sda2 and sda3 are
ntfs partitions that are 74.32gb each to match the size of the partition I
want ddrescue to copy off my bad laptop drive), sda4 is an ext3 12gb
partition I made for the ddrescue logfile and scratchfiles, etc.

The problem comes when I try to start ddrescue from the live cd terminal to
have it copy my bad hd partition hda1 which is on the laptop hd installed in
the ide slot. I want it to send that copy to the empty ntfs partition of
matching size I created on the external drive (sda2 or sda3) and I want the
logfile to go to the new ext3 partition (sda4). 

Here is the command I have been trying:

# ddrescue -n /dev/hda1 /dev/sda2 /dev/sda4/baddisk.log

but everytime I've tried I get an error that says: ddrescue: cannot open
output file: not a directory

I've also tried /dev/sda3, /dev/sda2/test (after creating a folder called
'test'), /dev/sda2/test/baddisk.img, but I continue to get the same error.

I'd be willing to bet I'm overlooking something obvious, but I'm stumped.
Any ideas?

Aaron Hartwell
View this message in context: 
Sent from the Gnu - ddrescue mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]