[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS 1.11.5 Login Error

From: Andy Cheong Kok Mung
Subject: CVS 1.11.5 Login Error
Date: Wed, 19 Mar 2003 15:22:11 +0800

i am a newbie to the cvs, and i am experiencing errors with the setting up 
process of cvs
it gave me this error of :
cvs [login aborted]: end of file from server (consult above messages if any)

i have currently downloaded the source code for cvs 1.11.5 from the cvshome 
and compiled it on the sun solaris 2.8 operation system,
the following steps are taken:
(1) gzip -d cvs-*.gz (for decompressing the source file to tar format)
(2) i copy the file to the directory of /usr/ibm/
(3) then i tar xvf the tar file , and it produce the directory of 
/usr/ibm/cvs-1.11.5, followed by the respective subdirectories
(4) thereafter, i run the command
    ./noautomake.sh --noautoconf
(5) the command 
    ./configure (is run)
(6) make (is run)
(7) make install (is run)
(8) then i initialize the repository which i created (/src/repository)
     cvs -d /src/repository init
(9) then i make changes to my /etc/inetd.conf 
     in the etc/inetd/inetd.conf : the following is added

    cvspserver stream tcp nowait root /usr/ibm/cvs-1.11.5
    cvs -f --allow-root=/usr/repository pserver

(10) in the etc/inetd/services : the following is added

    cvspserver 2401/tcp

(11) then i chmod u-w for the above services and inetd.conf file, to make them 

(12) then i restart the inetd and services using:
    pkill -HUP inetd

(13) the services seem to run correctly as i manage to sift the desired output 
      netstat -an | grep '2401'

(14) then i tried this: 
      cvs -d :pserver:address@hidden:$CVSROOT login
     it shows:

     Logging in to :pserver:address@hidden:2401/src/repository
     CVS password:

     after keying in the password: (this error msg shows up)
    cvs [login aborted]: end of file from server (consult above messages if any)

would appreciate any advice given:))
it seems that not even login validation of password is done, otherwise they 
would give password or authentication error.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]