bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FW: Empty file name


From: Ellison, Martin [IT]
Subject: FW: Empty file name
Date: Fri, 10 Aug 2001 10:21:46 +1000

Further to this, I have looked into the code a bit and it seems that the
filename in an RCSNode is null. The RCSNode (which seems to contain
information about an RCS file) is part of a Vers_TS (which seems to contain
the CVS information about a file).

-----Original Message-----
I raised this yesterday on the info-cvs list. It looks to me like a defect
-- if I'm doing something wrong it should at least give me a better message.

I entered: cvs checkout CVSROOT    [it does the same for any module]

It gives (with -t set on the server):

S-> do_module (CVSROOT, Updating, , )
S-> do_module (CVSROOT, Updating, , )
S-> unlink_file(./CVS/Entries.Static)
cvs server: Updating CVSROOT
cvs [server aborted]: cannot stat : No such file or directory
cvs [server aborted]: cannot stat : No such file or directory

CVS seems to be forming an empty file name for some reason.

(I grepped the source for the message "cannot stat" and found 17 different
locations for this message. So it might be a good idea sometime to print
some indication of where an error is coming from -- either unique message
codes or filename/linenumber pair -- or do we need to keep error messages
consistent across versions?).

Although I'm running Corey's code, I pulled off his options (i.e. inetd now
runs a script that just does cvs --include-root=<whatever> pserver) and I
still get the same behaviour.

Does anyone know what the problem is?

Regards,
Martin

-----Original Message-----

Does anyone know the cause of the following?

I am using 1.11.1p1 with Corey's perm9 patch for both client and pserver.

_______________________________________________
Bug-cvs mailing list
address@hidden
http://mail.gnu.org/mailman/listinfo/bug-cvs



reply via email to

[Prev in Thread] Current Thread [Next in Thread]