bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error in CVS Manual


From: Gary Farmer
Subject: Error in CVS Manual
Date: Thu, 9 Aug 2001 17:38:41 -0500

I have been reading the CVS manual at
http://www.cvshome.org/docs/manual/cvs_2.html#SEC26.
In section 2.9.2, "Connecting with rsh", it gives an
example of a remote cvs command:

  cvs -d :ext:address@hidden/usr/local/cvsroot checkout foo

I duplicated this as closely as I could, but it would not
work.  It kept saying:

  cvs checkout: didn't specify hostname in CVSROOT:
:ext:fsats1.arlut.utexas.edu/usr/fsats/cvs
  cvs [checkout aborted]: Bad CVSROOT.

I finally searched some email archived and found
another example:

  CVSROOT=:ext:localhost:/repository

This indicates a colon between hostname and CVSROOT.
I tried this and it worked.  The equivalent in the above
example would be:

  cvs -d :ext:address@hidden:/usr/local/cvsroot checkout foo
                 NOTE THE COLON ---^

This cost me an hour or so.  I recommend it be fixed in the
manual.  It should be trivial to fix.

Gary Farmer






reply via email to

[Prev in Thread] Current Thread [Next in Thread]