bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

strange cvs behavior on a large filesystem


From: JB Gallagher
Subject: strange cvs behavior on a large filesystem
Date: Tue, 31 Jul 2001 18:33:03 -0500

Hello,

My name is Brad Gallagher and I work for a team of coders who heavily
use CVS for the code they are developing. On the main development
machine, which is an SGI running IRIX 6.5.12m, a 2 terabyte RAID array
was recently added. CVS refuses to checkout any modules to this
filesystem, unless you go through the pserver running on the same
system.  So a given repository will checkout fine when CVSROOT is set to
":local:/home/cvsroot" as long as your working directory is not within
the directory this new large filesystem is mounted on, but as soon as
you change the CVSROOT variable to point to the pserver running out of
inted on the same system, it will again checkout any module just fine.
Any ideas?  The error I get is one I've found to be documented well on
the net, but the circumstances in which I'm getting this error seem to
be all together different. Here is the error:

$CVSROOT = ":local:/home/csvroot"

cvs checkout: in directory FLASH1.61:
cvs [checkout aborted]: there is no version here; run 'cvs checkout'
first

Again, as soon as I change $CVSROOT = ":pserver:address@hidden:/home/cvsroot"
the error disappears and everything works fine. This strange behavior
only occurs on this new 2 terabyte filesystem.

thanks in advance,

Brad Gallagher
University of Chicago
ASCI Flash Center
address@hidden






reply via email to

[Prev in Thread] Current Thread [Next in Thread]