bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Derek, could you please check in automake instructions?


From: Karl Fogel
Subject: Re: Derek, could you please check in automake instructions?
Date: 26 Dec 2000 12:32:00 -0600

"Derek R. Price" <address@hidden> writes:
> > Building the old way
> >
> >    ./configure --prefix=/usr/local
> >    make
> >
> > failed because lib/Makefile contains some unsubstituted autoconf
> > macros.  I assume this is related to the recent automake switchover.
> 
> This should have worked.  Basically, an old autoconf works fine
> because the new aclocal.m4 file has all the automake specific m4
> macros in it.  I'm going to guess that while you were playing with
> the 1.4 automake you ran aclocal and replaced your aclocal.m4 file
> with a broken one and regenerated configure.  Some of this behavior
> may have been due to some files which had improper timestamps.  I
> fixed that today. 

Nope.  The very first thing I did was try the old configure/make
method, which failed.  I didn't start fooling with automake until
after that.

> I'll try and check in some notes about common Automake problems
> anyhow.  And more as I receive more reports.

Thanks.

> Also, I say everything _should_ be working, but I'm still
> discovering problems on Larry Jones' test machines.  I'm fixing them
> as Larry tells me about them but there are some remaining known
> problems on BSD machines which I am working on with the Automake
> people.

I'll do 

   cvs update
   make distclean
   ./configure --prefix=/usr/local/
   make

and let you know what happens.

-Karl



reply via email to

[Prev in Thread] Current Thread [Next in Thread]