[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Derek, could you please check in automake instructions?

From: Derek R. Price
Subject: Re: Derek, could you please check in automake instructions?
Date: Tue, 26 Dec 2000 15:43:35 -0500

Karl Fogel wrote:

> Or better yet, an `autogen.sh'-like build-from-scratch script? :-)
> It's not clear whether people building from the working tree are
> supposed to run automake, or use the pregenerated `Makefile.in's
> (which are still present).

'configure' & pregenerated 'Makefile.in's should be used, unless they changed
'configure.in' or one of the 'Makefile.am' files and have Automake & Autoconf
installed.  If Automake & Autoconf aren't installed and 'configure.in' or a
'Makefile.am' have changed, everything should still build with warnings but the 
may not be propogated to 'Makefile.in's and 'Makefile's.

> I tried both.  Using automake failed because I only have automake 1.4,
> not the required 1.4a.  Where did you get 1.4a?  The main GNU ftp site
> still only has 1.4.  Don't mind depending on bleeding edge tools, but
> have to be able to find them. :-)

1.4a was a dev version in a CVS repository.  They just released 1.4b.  You 
could use
that version, but I've been maintaining a distro with some useful patches which 
gotten into the main Automake yet:


The source RPMs have my patches separated from the official Automake source.

I'm looking into getting some FTP space on ftp.cvshome.org, but I don't know 
when that
might happen.  Until then I'll keep updates in the umich account and post 
notices to the
mailing lists when it seems relevant.

Also, uninstalling Automake entirely should allow the build to work properly as 
well.  I
haven't looked closely at what happens with a broken Automake.

> Building the old way
>    ./configure --prefix=/usr/local
>    make
> failed because lib/Makefile contains some unsubstituted autoconf
> macros.  I assume this is related to the recent automake switchover.

This should have worked.  Basically, an old autoconf works fine because the new
aclocal.m4 file has all the automake specific m4 macros in it.  I'm going to 
guess that
while you were playing with the 1.4 automake you ran aclocal and replaced your
aclocal.m4 file with a broken one and regenerated configure.  Some of this 
behavior may
have been due to some files which had improper timestamps.  I fixed that today.

I'll try and check in some notes about common Automake problems anyhow.  And 
more as I
receive more reports.

Also, I say everything _should_ be working, but I'm still discovering problems 
on Larry
Jones' test machines.  I'm fixing them as Larry tells me about them but there 
are some
remaining known problems on BSD machines which I am working on with the 
Automake people.


Derek Price                      CVS Solutions Architect ( http://CVSHome.org )
mailto:address@hidden     OpenAvenue ( http://OpenAvenue.com )
Remember folks: Stop lights timed for 35mph are also timed for 70mph.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]