bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS 1.11.0.1 support for GSSAPI and KERBEROS4 on Windows


From: Jeffrey Altman
Subject: CVS 1.11.0.1 support for GSSAPI and KERBEROS4 on Windows
Date: Fri, 1 Dec 2000 0:57:50 EST

Concurrent Versions System (CVS) 1.11.0.1 (client) fails to compile
out of the box on Windows when compiled to support MIT Kerberos for
Windows.  Both the GSSAPI and the KERBEROS4 support are broken.  In
fact, I would be surprised if the GSSAPI support would compile on Unix
at all.

KERBEROS4 support is broken on all platforms unless the old Cygnus
Kerb4 distribution is being used.  The header file krb.h is locaated
in KerberosIV/krb.h when Kerberos 5 version 1.x.x is used.  (in other
words on all modern day systems.)

If you are interested in the patches for these issues please send me a
note.  I don't want to waste my time constructing patches if no one
cares.  

---

On a side note: I would be interested in implementing TLS support for
CVS using OpenSSL.  I plan to do this for myself.  If you would be
interested in those changes as well, let me know.

Thanks for maintaining this software.



                  Jeffrey Altman * Sr.Software Designer
                 The Kermit Project * Columbia University
               612 West 115th St * New York, NY * 10025 * USA
     http://www.kermit-project.org/ * address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]